Segment Routing PCE Multi Area

今回はPCEを使用して、OSPFのマルチエリアに跨るSR-TE用のLSPを構築する方法を説明します。

 

概要

Disjoint Pathについて

OSPFの仕様上、マルチエリア構成の場合、特定のエリアのルータは別のエリアのTE用のLSAを学習できません。(TE用のLSAのFlooding ScopeがAreaなので)
その結果、各ルータは別のエリアの構造やリンクのColor等が分からないため、複数のエリアに跨るSR-TE用のLSPを構築できません。

 

複数のエリアに跨るSR-TE用のLSPを構築するには、PCEとBGP-LSを併用する必要があります。
最初に、BGP-LSを使用して、PCEとして動作させるルータに各エリアのLSAを学習させます。そして、Head-endでSR-TE用のLSPを生成する際に、PCEにLSPの計算を依頼します。PCEは各エリアのLSAを学習しているため、複数のエリアに跨るSR-TE用のLSPを計算できます。

 

検証内容と設定

基本設定の内容

R1-R2間でOSPF Area 0、R2-R3間とR2-R4間とR3-R4間でOSPF Area 1を構成します。
OSPFでSR-TEを有効にします。

R1、R5、R3をAS 100に所属させます。
R1-R5間、R3-R5間でIBGPネイバーを構成します。
R1とR3はR5に対して、IBGP経由でOSPFのLSDBの情報を広報します。

R1-R2間、R2-R4間、R3-R4間のリンクにColor REDを割り当てます。
R2-R3間のリンクにColor BLUEを割り当てます。

R1でLoopback Interfaceの1.1.1.1/32にPrefix SIDとして20101を割り当てます。
R3でLoopback Interfaceの2.2.2.2/32にPrefix SIDとして20201を割り当てます。
R3でLoopback Interfaceの3.3.3.3/32にPrefix SIDとして20301を割り当てます。
R4でLoopback Interfaceの4.4.4.4/32にPrefix SIDとして20401を割り当てます。

R5をPCE、R1をPCCとして動作させます。

 

 

 

初期設定


interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 172.16.1.1 255.255.255.0
!
router ospf 1
 distribute link-state instance-id 1
 router-id 1.1.1.1
 segment-routing mpls
 area 0
  mpls traffic-eng
  interface Loopback0
   prefix-sid absolute 20101
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
 !
!
router bgp 100
 bgp router-id 1.1.1.1
 address-family ipv4 unicast
 !
 address-family link-state link-state
 !
 neighbor 3.3.3.3
  remote-as 100
  update-source Loopback0
  address-family ipv4 unicast
  !
 !
 neighbor 172.16.1.5
  remote-as 100
  address-family link-state link-state
  !
 !
!
segment-routing
 traffic-eng
  interface GigabitEthernet0/0/0/0
   affinity
    name RED
   !
  !
  affinity-map
   name RED bit-position 0
   name BLUE bit-position 1
  !
  pcc
   source-address ipv4 172.16.1.1
   pce address ipv4 172.16.1.5
            


interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.1.2 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 10.2.2.2 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 10.3.3.2 255.255.255.0
!
router ospf 1
 router-id 2.2.2.2
 segment-routing mpls
 area 0
  mpls traffic-eng
  interface Loopback0
   prefix-sid absolute 20201
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
 !
 area 1
  mpls traffic-eng
  interface GigabitEthernet0/0/0/1
   network point-to-point
  !
  interface GigabitEthernet0/0/0/2
   network point-to-point
  !
 !
!
segment-routing
 traffic-eng
  interface GigabitEthernet0/0/0/0
   affinity
    name RED
   !
  !
  interface GigabitEthernet0/0/0/1
   affinity
    name BLUE
   !
  !
  interface GigabitEthernet0/0/0/2
   affinity
    name RED
   !
  !
  affinity-map
   name RED bit-position 0
   name BLUE bit-position 1
            


interface Loopback0
 ipv4 address 3.3.3.3 255.255.255.0
!
interface Loopback1
 ipv4 address 10.5.5.3 255.255.255.0
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.2.2.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 10.4.4.3 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 172.16.1.3 255.255.255.0
!
router ospf 1
 distribute link-state instance-id 1
 router-id 3.3.3.3
 segment-routing mpls
 area 1
  mpls traffic-eng
  interface Loopback0
   prefix-sid absolute 20301
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/1
   network point-to-point
  !
 !
!
router bgp 100
 bgp router-id 3.3.3.3
 address-family ipv4 unicast
  network 10.5.5.0/24
 !
 address-family link-state link-state
 !
 neighbor 1.1.1.1
  remote-as 100
  update-source Loopback0
  address-family ipv4 unicast
   route-policy BGP_ROUTE_POLICY out
  !
 !
 neighbor 172.16.1.5
  remote-as 100
  address-family link-state link-state
  !
 !
!
segment-routing
 traffic-eng
  interface GigabitEthernet0/0/0/0
   affinity
    name BLUE
   !
  !
  interface GigabitEthernet0/0/0/1
   affinity
    name RED
   !
  !
  affinity-map
   name RED bit-position 0
   name BLUE bit-position 1
  !
  pcc
   source-address ipv4 172.16.1.3
   pce address ipv4 172.16.1.5
            


interface Loopback0
 ipv4 address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.3.3.4 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 10.4.4.4 255.255.255.0
!
router ospf 1
 router-id 4.4.4.4
 segment-routing mpls
 area 1
  mpls traffic-eng
  interface Loopback0
   prefix-sid absolute 20401
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/1
   network point-to-point
  !
 !
!
segment-routing
 traffic-eng
  interface GigabitEthernet0/0/0/0
   affinity
    name RED
   !
  !
  interface GigabitEthernet0/0/0/1
   affinity
    name RED
   !
  !
  affinity-map
   name RED bit-position 0
   name BLUE bit-position 1
            


pce
 address ipv4 172.16.1.5
!
interface GigabitEthernet0/0/0/0
 ipv4 address 172.16.1.5 255.255.255.0
!
router bgp 100
 bgp router-id 5.5.5.5
 address-family link-state link-state
 !
 neighbor 172.16.1.1
  remote-as 100
  address-family link-state link-state
  !
 !
 neighbor 172.16.1.3
  remote-as 100
  address-family link-state link-state
            

 

OSPFの状態確認

R1のLSDBを見ると、エリア1のOpaque LSAが存在しないことが確認できます。この結果、R1はエリア1のTE用の情報を認識できていないことが分かります。

R1

RP/0/RP0/CPU0:R1#show ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         232         0x80000004 0x002fb2 3
2.2.2.2         2.2.2.2         198         0x80000004 0x00cf08 3

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
3.3.3.3         2.2.2.2         198         0x80000002 0x00d451
4.4.4.4         2.2.2.2         198         0x80000002 0x00a67b
10.2.2.0        2.2.2.2         198         0x80000002 0x00a480
10.3.3.0        2.2.2.2         198         0x80000002 0x008d95
10.4.4.0        2.2.2.2         198         0x80000002 0x00809f

                Type-10 Opaque Link Area Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Opaque ID
1.0.0.0         1.1.1.1         231         0x80000003 0x0054d3        0
1.0.0.0         2.2.2.2         198         0x80000002 0x005ac6        0
1.0.0.7         1.1.1.1         231         0x80000002 0x0059a3        7
1.0.0.7         2.2.2.2         198         0x80000002 0x00e01c        7
4.0.0.0         1.1.1.1         231         0x80000003 0x008734        0
4.0.0.0         2.2.2.2         198         0x80000003 0x00a90d        0
7.0.0.1         1.1.1.1         231         0x80000002 0x00dda3        1
7.0.0.1         2.2.2.2         198         0x80000002 0x0024f0        1
7.0.0.2         2.2.2.2         198         0x80000002 0x005118        2
7.0.0.3         2.2.2.2         198         0x80000002 0x00aa55        3
8.0.0.7         1.1.1.1         231         0x80000002 0x00c041        7
8.0.0.7         2.2.2.2         198         0x80000002 0x00f50d        7
            

 

BGP-LSの状態確認

R5のBGP-LSのテーブルを見ると、R5はR1~R4のLSAを学習していることが確認できます。

R5

RP/0/RP0/CPU0:R5#show bgp link-state link-state
BGP router identifier 5.5.5.5, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 34
BGP main routing table version 34
BGP NSR Initial initsync version 14 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Prefix codes: E link, V node, T IP reacheable route, S SRv6 SID, u/U unknown
              I Identifier, N local node, R remote node, L link, P prefix, S SID
              L1/L2 ISIS level-1/level-2, O OSPF, D direct, S static/peer-node
              a area-ID, l link-ID, t topology-ID, s ISO-ID,
              c confed-ID/ASN, b bgp-identifier, r router-ID, s SID
              i if-address, n nbr-address, o OSPF Route-type, p IP-prefix
              d designated router address
   Network            Next Hop            Metric LocPrf Weight Path
*>i[V][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r1.1.1.1]]/376
                      172.16.1.1                    100      0 i
*>i[V][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]]/376
                      172.16.1.1                    100      0 i
*>i[V][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]]/376
                      172.16.1.3                    100      0 i
*>i[V][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r3.3.3.3]]/376
                      172.16.1.3                    100      0 i
*>i[V][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r4.4.4.4]]/376
                      172.16.1.3                    100      0 i
*>i[E][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r1.1.1.1]][R[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][L[i10.1.1.1][n10.1.1.2]]/792
                      172.16.1.1                    100      0 i
*>i[E][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][R[c100][b0.0.0.0][a0.0.0.0][r1.1.1.1]][L[i10.1.1.2][n10.1.1.1]]/792
                      172.16.1.1                    100      0 i
*>i[E][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][R[c100][b0.0.0.0][a0.0.0.1][r3.3.3.3]][L[i10.2.2.2][n10.2.2.3]]/792
                      172.16.1.3                    100      0 i
*>i[E][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][R[c100][b0.0.0.0][a0.0.0.1][r4.4.4.4]][L[i10.3.3.2][n10.3.3.4]]/792
                      172.16.1.3                    100      0 i
*>i[E][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r3.3.3.3]][R[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][L[i10.2.2.3][n10.2.2.2]]/792
                      172.16.1.3                    100      0 i
*>i[E][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r3.3.3.3]][R[c100][b0.0.0.0][a0.0.0.1][r4.4.4.4]][L[i10.4.4.3][n10.4.4.4]]/792
                      172.16.1.3                    100      0 i
*>i[E][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r4.4.4.4]][R[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][L[i10.3.3.4][n10.3.3.2]]/792
                      172.16.1.3                    100      0 i
*>i[E][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r4.4.4.4]][R[c100][b0.0.0.0][a0.0.0.1][r3.3.3.3]][L[i10.4.4.4][n10.4.4.3]]/792
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r1.1.1.1]][P[o0x01][p10.1.1.0/24]]/480
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r1.1.1.1]][P[o0x01][p1.1.1.1/32]]/488
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][P[o0x01][p10.1.1.0/24]]/480
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][P[o0x01][p2.2.2.2/32]]/488
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][P[o0x02][p10.2.2.0/24]]/480
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][P[o0x02][p10.3.3.0/24]]/480
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][P[o0x02][p10.4.4.0/24]]/480
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][P[o0x02][p3.3.3.3/32]]/488
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.0][r2.2.2.2]][P[o0x02][p4.4.4.4/32]]/488
                      172.16.1.1                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][P[o0x01][p10.2.2.0/24]]/480
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][P[o0x01][p10.3.3.0/24]]/480
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][P[o0x02][p10.1.1.0/24]]/480
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][P[o0x02][p1.1.1.1/32]]/488
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r2.2.2.2]][P[o0x02][p2.2.2.2/32]]/488
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r3.3.3.3]][P[o0x01][p10.2.2.0/24]]/480
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r3.3.3.3]][P[o0x01][p10.4.4.0/24]]/480
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r3.3.3.3]][P[o0x01][p3.3.3.3/32]]/488
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r4.4.4.4]][P[o0x01][p10.3.3.0/24]]/480
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r4.4.4.4]][P[o0x01][p10.4.4.0/24]]/480
                      172.16.1.3                    100      0 i
*>i[T][O][I0x1][N[c100][b0.0.0.0][a0.0.0.1][r4.4.4.4]][P[o0x01][p4.4.4.4/32]]/488
                      172.16.1.3                    100      0 i

Processed 33 prefixes, 33 paths
            

 

SR-TE DBの状態確認

R5のSR-TE DBを見ると、エリア0とエリア1のTE用の情報を学習していることが確認できます。

R5

RP/0/RP0/CPU0:R5#show pce ipv4 topology traffic-eng 2.2.2.2

PCE's topology database - detail:
---------------------------------
Node 2
  TE router ID: 2.2.2.2
  OSPF router ID: 2.2.2.2 area ID: 0 ASN: 100 domain ID: 1
  OSPF router ID: 2.2.2.2 area ID: 1 ASN: 100 domain ID: 1
  Prefix SID:
    OSPF router ID: 2.2.2.2 area ID: 0 ASN: 100 domain ID: 1
      Prefix 2.2.2.2, label 20201 (regular), flags: N:1, R:0, P:0, V:0, E:0, L:0
  SRGB INFO:
    OSPF router ID: 2.2.2.2 area ID: 0 ASN: 100 domain ID: 1
      SRGB Start: 16000 Size: 8000
    OSPF router ID: 2.2.2.2 area ID: 1 ASN: 100 domain ID: 1
      SRGB Start: 16000 Size: 8000

  Link[0]: local address 10.1.1.2, remote address 10.1.1.1
    Local node:
      OSPF router ID: 2.2.2.2 area ID: 0 ASN: 100 domain ID: 1
    Remote node:
      TE router ID: 1.1.1.1
      OSPF router ID: 1.1.1.1 area ID: 0 ASN: 100 domain ID: 1
    Metric: IGP 1, TE 1, Latency 1 microseconds
    Bandwidth: Total 125000000 Bps, Reservable 0 Bps
    Admin-groups: 0x00000001
    Adj SID: 24000 (unprotected)

  Link[1]: local address 10.2.2.2, remote address 10.2.2.3
    Local node:
      OSPF router ID: 2.2.2.2 area ID: 1 ASN: 100 domain ID: 1
    Remote node:
      TE router ID: 3.3.3.3
      OSPF router ID: 3.3.3.3 area ID: 1 ASN: 100 domain ID: 1
    Metric: IGP 1, TE 1, Latency 1 microseconds
    Bandwidth: Total 125000000 Bps, Reservable 0 Bps
    Admin-groups: 0x00000002
    Adj SID: 24001 (unprotected)

  Link[2]: local address 10.3.3.2, remote address 10.3.3.4
    Local node:
      OSPF router ID: 2.2.2.2 area ID: 1 ASN: 100 domain ID: 1
    Remote node:
      TE router ID: 4.4.4.4
      OSPF router ID: 4.4.4.4 area ID: 1 ASN: 100 domain ID: 1
    Metric: IGP 1, TE 1, Latency 1 microseconds
    Bandwidth: Total 125000000 Bps, Reservable 0 Bps
    Admin-groups: 0x00000001
    Adj SID: 24002 (unprotected)
            

 

PCEを使用しない場合

SR-TE Policyの設定

R1でEnd-pointが3.3.3.3、かつ、Color REDのリンクのみを使用するSR-TE Policyを設定します。PCEにはLSPの計算は依頼しません。

R1

segment-routing
 traffic-eng
  policy SR-TE_POLICY
   color 1 end-point ipv4 3.3.3.3
   candidate-paths
    preference 10
     dynamic
     !
     constraints
      affinity
       include-any
        name RED
            

 

SR-TE Policyの状態確認

R1はエリア1のリンクの情報を知らないため、SR-TEのLSPの計算に失敗していることが確認できます。

R1

RP/0/RP0/CPU0:R1#show segment-routing traffic-eng policy

SR-TE policy database
---------------------

Color: 1, End-point: 3.3.3.3
  Name: srte_c_1_ep_3.3.3.3
  Status:
    Admin: up  Operational: down for 00:21:55 (since Jun 28 08:40:47.686)
  Candidate-paths:
    Preference: 10 (configuration)
      Name: SR-TE_POLICY
      Requested BSID: dynamic
      Constraints:
        Affinity:
          include-any:
          RED
        Maximum SID Depth: 10
      Dynamic (invalid)
      Last error: No path found
        Metric Type: TE,   Path Accumulated Metric: 0
  Attributes:
    Forward Class: 0
    Steering labeled-services disabled: no
    Steering BGP disabled: no
    IPv6 caps enable: no
            

 

PCEを使用した場合

SR-TE Policyの設定

R1でEnd-pointが3.3.3.3、かつ、Color REDのリンクのみを使用するSR-TE Policyを設定します。また、PCEにLSPの計算を依頼します。

R1

segment-routing
 traffic-eng
  policy SR-TE_POLICY
   color 1 end-point ipv4 3.3.3.3
   candidate-paths
    preference 10
     dynamic
      pcep
     !
     constraints
      affinity
       include-any
        name RED
            

 

PCEの状態確認

R5はBGP-LS経由で学習したOSPFのエリア0とエリア1のLSAの情報を基に、エリア0からエリア1に跨るLSPを計算できていることが確認できます。

R5

RP/0/RP0/CPU0:R5#show pce lsp detail

PCE's tunnel database:
----------------------
PCC 172.16.1.1:

Tunnel Name: cfg_SR-TE_POLICY_discr_10
Color: 1
Interface Name: srte_c_1_ep_3.3.3.3
 LSPs:
  LSP[0]:
   source 1.1.1.1, destination 3.3.3.3, tunnel ID 4, LSP ID 1
   State: Admin up, Operation up
   Setup type: Segment Routing
   Binding SID: 24002
   Maximum SID Depth: 10
   Preference: 10
   Bandwidth: signaled 0 kbps, applied 0 kbps
   Affinity: exclude-any 0x0 include-any 0x1 include-all 0x0
   PCEP information:
     PLSP-ID 0x3, flags: D:1 S:0 R:0 A:1 O:1 C:0
   LSP Role: Single LSP
   State-sync PCE: None
   PCC: 172.16.1.1
   LSP is subdelegated to: None
   Reported path:
     Metric type: TE, Accumulated Metric 3
      SID[0]: Node, Label 20201, Address 2.2.2.2
      SID[1]: Node, Label 20401, Address 4.4.4.4
      SID[2]: Node, Label 20301, Address 3.3.3.3
   Computed path: (Local PCE)
     Computed Time: Sun Jun 28 09:05:05 UTC 2020 (00:00:13 ago)
     Metric type: TE, Accumulated Metric 3
      SID[0]: Node, Label 20201, Address 2.2.2.2
      SID[1]: Node, Label 20401, Address 4.4.4.4
      SID[2]: Node, Label 20301, Address 3.3.3.3
   Recorded path:
     None
   Disjoint Group Information:
     None
            

 

SR-TE Policyの状態確認

R1はR5からエリア0からエリア1に跨るLSPを学習していることが確認できます。

R1

RP/0/RP0/CPU0:R1#show segment-routing traffic-eng policy

SR-TE policy database
---------------------

Color: 1, End-point: 3.3.3.3
  Name: srte_c_1_ep_3.3.3.3
  Status:
    Admin: up  Operational: up for 00:00:56 (since Jun 28 09:04:38.052)
  Candidate-paths:
    Preference: 10 (configuration) (active)
      Name: SR-TE_POLICY
      Requested BSID: dynamic
      PCC info:
        Symbolic name: cfg_SR-TE_POLICY_discr_10
        PLSP-ID: 3
      Constraints:
        Affinity:
          include-any:
          RED
        Maximum SID Depth: 10
      Dynamic (pce 172.16.1.5) (valid)
        Metric Type: TE,   Path Accumulated Metric: 3
          20201 [Prefix-SID, 2.2.2.2]
          20401 [Prefix-SID, 4.4.4.4]
          20301 [Prefix-SID, 3.3.3.3]
  Attributes:
    Binding SID: 24002
    Forward Class: Not Configured
    Steering labeled-services disabled: no
    Steering BGP disabled: no
    IPv6 caps enable: yes
            

 

疎通確認

R1の1.1.1.1からR3の3.3.3.3へTracerouteを実施します。

 

パケットがColor REDのリンクのみ経由していることが確認できます。

R1

RP/0/RP0/CPU0:R1#traceroute 10.5.5.3 source 1.1.1.1

Type escape sequence to abort.
Tracing the route to 10.5.5.3

 1  10.1.1.2 [MPLS: Labels 20401/20301 Exp 0] 28 msec  33 msec  19 msec
 2  10.3.3.4 [MPLS: Label 20301 Exp 0] 19 msec  18 msec  21 msec
 3  10.4.4.3 19 msec  *  16 msec
            

コメント

タイトルとURLをコピーしました