Segment Routing BGP Link State – IS-IS

今回はBGP-LSを使用して、IS-ISのLSDBの情報を広報する方法を説明します。。

 

概要

BGP-LSによるIS-ISのLSDBの広報

OSPFと同様に、SR-TE DBに投入されたIS-ISのLSDBの情報をBGP-LSで広報することが可能です。

 

検証内容と設定

基本設定の内容

R1-R2間でIS-IS Area 49.0000を構成します。
R1とR2をL2 Routerとして動作させます。
OSPFでSR-TEを有効にします。

R1でLoopback Interfaceの1.1.1.1/32にPrefix SIDとして20101を割り当てます。
R2でLoopback Interfaceの2.2.2.2/32にPrefix SIDとして20201を割り当てます。

R1とR3をAS 100に所属させ、IBGPネイバーを構成します。
R1はR3に対して、IBGP経由でIS-ISのLSDBの情報を広報します。

 

初期設定


interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 10.2.2.1 255.255.255.0
!
router isis 1
 is-type level-2-only
 net 49.0001.0000.0000.0001.00
 distribute link-state instance-id 32
 address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-2-only
  segment-routing mpls
 !
 interface Loopback0
  address-family ipv4 unicast
   prefix-sid absolute 20101
  !
 !
 interface GigabitEthernet0/0/0/0
  point-to-point
  address-family ipv4 unicast
  !
 !
!
router bgp 100
 bgp router-id 1.1.1.1
 address-family link-state link-state
 !
 neighbor 10.2.2.3
  remote-as 100
  address-family link-state link-state
  !
 !
!
router bgp 100
 bgp router-id 1.1.1.1
 address-family link-state link-state
 !
 neighbor 10.2.2.3
  remote-as 100
  address-family link-state link-state
            


interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.1.2 255.255.255.0
!
router isis 1
 is-type level-2-only
 net 49.0001.0000.0000.0002.00
 address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-2-only
  segment-routing mpls
 !
 interface Loopback0
  address-family ipv4 unicast
   prefix-sid absolute 20201
  !
 !
 interface GigabitEthernet0/0/0/0
  point-to-point
  address-family ipv4 unicast
  !
 !
!
segment-routing
 traffic-eng
            


interface GigabitEthernet0/0/0/0
 ipv4 address 10.2.2.3 255.255.255.0
!
router bgp 100
 bgp router-id 3.3.3.3
 address-family link-state link-state
 !
 neighbor 10.2.2.1
  remote-as 100
  address-family link-state link-state
            

 

設定と状態確認

BGPの設定

BGPではプロセス単位、ネイバー単位でaddress-family link-state link-stateコマンドを設定し、BGP-LSを有効にします。

R1

router bgp 100
 bgp router-id 1.1.1.1
 address-family link-state link-state
 !
 neighbor 10.2.2.3
  remote-as 100
  address-family link-state link-state
            

 

IS-ISの設定

IS-ISではdistribute link-state instance-id <id>コマンドを設定し、LSDBの情報をSR-TE DBに投入します。

R1

router isis 1
 distribute link-state instance-id 32
            

 

BGP-LSのルート情報の確認

BGP-LSのルート情報はshow bgp link-state link-stateコマンド

R1

RP/0/RP0/CPU0:R3#show bgp link-state link-state
BGP router identifier 1.1.1.1, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 30
BGP main routing table version 30
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Prefix codes: E link, V node, T IP reacheable route, S SRv6 SID, u/U unknown
              I Identifier, N local node, R remote node, L link, P prefix, S SID
              L1/L2 ISIS level-1/level-2, O OSPF, D direct, S static/peer-node
              a area-ID, l link-ID, t topology-ID, s ISO-ID,
              c confed-ID/ASN, b bgp-identifier, r router-ID, s SID
              i if-address, n nbr-address, o OSPF Route-type, p IP-prefix
              d designated router address
   Network            Next Hop            Metric LocPrf Weight Path
*> [V][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]]/328
                      0.0.0.0                                0 i
*> [V][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0002.00]]/328
                      0.0.0.0                                0 i
*> [E][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]][R[c100][b0.0.0.0][s0000.0000.0002.00]][L[i10.1.1.1][n10.1.1.2]]/696
                      0.0.0.0                                0 i
*> [E][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0002.00]][R[c100][b0.0.0.0][s0000.0000.0001.00]][L[i10.1.1.2][n10.1.1.1]]/696
                      0.0.0.0                                0 i
*> [T][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]][P[p10.1.1.0/24]]/392
                      0.0.0.0                                0 i
*> [T][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]][P[p1.1.1.1/32]]/400
                      0.0.0.0                                0 i
*> [T][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0002.00]][P[p10.1.1.0/24]]/392
                      0.0.0.0                                0 i
*> [T][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0002.00]][P[p2.2.2.2/32]]/400
                      0.0.0.0                                0 i

Processed 8 prefixes, 8 paths
            

 

Node NLRI

以下はR1のNode NLRIになります。Area ID、System ID、SRGBの情報が格納されていることが確認できます。

R1

RP/0/RP0/CPU0:R1#show bgp link-state link-state [V][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]]/328 detail
BGP routing table entry for [V][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]]/328
NLRI Type: Node
Protocol: ISIS L2
Identifier: 0x20
Local Node Descriptor:
        AS Number: 100
        BGP Identifier: 0.0.0.0
        ISO Node ID: 0000.0000.0001.00

Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 25          25
    Flags: 0x00000001+0x00000000;
Last Modified: Jul 19 20:11:27.688 for 00:01:30
Paths: (1 available, best #1)
  Advertised to peers (in unique update groups):
    10.2.2.3
  Path #1: Received by speaker 0
  Flags: 0x400000000104000b, import: 0x20
  Advertised to peers (in unique update groups):
    10.2.2.3
  Local
    0.0.0.0 from 0.0.0.0 (1.1.1.1), if-handle 0x00000000
      Origin IGP, localpref 100, valid, redistributed, best, group-best
      Received Path ID 0, Local Path ID 1, version 25
      Link-state: MSD: Type 1 Value 10, Node-name: R1, ISIS area: 49.00.01
                   Local TE Router-ID: 1.1.1.1, SRGB: 16000:8000 , SR-ALG: 0
                  SR-ALG: 1  SRLB: 15000:1000

            

 

以下はR1のNode NLRIのMP_REACH_NLRIパスアトリビュートのキャプチャになります。System IDが格納されていることが確認できます。

 

以下はR1のNode NLRIのBGP-LSパスアトリビュートのキャプチャになります。Area ID、SRGBの先頭のSID、SRGBのサイズが格納されていることが確認できます。

 

Link NLRI

以下はR1のLink NLRIになります。Link NLRIにはネイバーのRouter ID、Link ColorなどのTE用の情報、Adjacency SID等が格納されていることが確認できます。

R1

RP/0/RP0/CPU0:R1#show bgp link-state link-state [E][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]][R[c100][b0.0.0.0][s0000.0000.0002.00]][L[i10.1.1.1][n10.1.1.2]]/696 detail
BGP routing table entry for [E][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]][R[c100][b0.0.0.0][s0000.0000.0002.00]][L[i10.1.1.1][n10.1.1.2]]/696
NLRI Type: Link
Protocol: ISIS L2
Identifier: 0x20
Local Node Descriptor:
        AS Number: 100
        BGP Identifier: 0.0.0.0
        ISO Node ID: 0000.0000.0001.00
Remote Node Descriptor:
        AS Number: 100
        BGP Identifier: 0.0.0.0
        ISO Node ID: 0000.0000.0002.00
Link Descriptor:
        Local Interface Address IPv4: 10.1.1.1
        Neighbor Interface Address IPv4: 10.1.1.2

Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 30          30
    Flags: 0x00000001+0x00000000;
Last Modified: Jul 19 20:11:27.688 for 00:02:11
Paths: (1 available, best #1)
  Advertised to peers (in unique update groups):
    10.2.2.3
  Path #1: Received by speaker 0
  Flags: 0x400000000104000b, import: 0x20
  Advertised to peers (in unique update groups):
    10.2.2.3
  Local
    0.0.0.0 from 0.0.0.0 (1.1.1.1), if-handle 0x00000000
      Origin IGP, localpref 100, valid, redistributed, best, group-best
      Received Path ID 0, Local Path ID 1, version 30
      Link-state: MSD: Type 1 Value 10, Local TE Router-ID:
                  1.1.1.1 Remote TE Router-ID: 2.2.2.2, admin-group: 0x00000000
                   max-link-bw (kbits/sec): 1000000, max-reserv-link-bw (kbits/sec): 0
                   max-unreserv-link-bw (kbits/sec): 0 0 0 0 0 0 0 0,
                  TE-default-metric: 10 metric: 10, ADJ-SID: 24001(30)
                   ext-admin-group: 0x00000000.0x00000000.0x00000000.0x00000000
                  .0x00000000.0x00000000.0x00000000.0x00000000

            

 

以下はR1のLink NLRIのMP_REACH_NLRIパスアトリビュートのキャプチャになります。ネイバーであるR2のSystem IDが格納されていることが確認できます。

 

以下はR1のLink NLRIのBGP-LSパスアトリビュートのキャプチャになります。Link ColorやAdjacency SID等が格納されていることが確認できます。

 

IPv4 Topology Prefix NLRI

以下はR1の1.1.1.1/32を格納したIPv4 Topology Prefix NLRIになります。PrefixとPrefix SIDのIndexが格納されていることが確認できます。

R1

RP/0/RP0/CPU0:R1#show bgp link-state link-state [T][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]][P[p1.1.1.1/32]]/400 detail
BGP routing table entry for [T][L2][I0x20][N[c100][b0.0.0.0][s0000.0000.0001.00]][P[p1.1.1.1/32]]/400
NLRI Type: Prefix
Protocol: ISIS L2
Identifier: 0x20
Local Node Descriptor:
        AS Number: 100
        BGP Identifier: 0.0.0.0
        ISO Node ID: 0000.0000.0001.00
Prefix Descriptor:
        Prefix: 1.1.1.1/32

Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 23          23
    Flags: 0x00000001+0x00000000;
Last Modified: Jul 19 20:11:27.688 for 00:03:00
Paths: (1 available, best #1)
  Advertised to peers (in unique update groups):
    10.2.2.3
  Path #1: Received by speaker 0
  Flags: 0x400000000104000b, import: 0x20
  Advertised to peers (in unique update groups):
    10.2.2.3
  Local
    0.0.0.0 from 0.0.0.0 (1.1.1.1), if-handle 0x00000000
      Origin IGP, localpref 100, valid, redistributed, best, group-best
      Received Path ID 0, Local Path ID 1, version 23
      Link-state: Metric: 10, PFX-SID: 4101(40/0) , Extended IGP flags: 0x20, Source Router ID: 1.1.1.1
            

 

以下はR1の1.1.1.1/32を格納したIPv4 Topology Prefix NLRIのMP_REACH_NLRIパスアトリビュートのキャプチャになります。Prefixが格納されていることが確認できます。

 

以下はR1の1.1.1.1/32を格納したIPv4 Topology Prefix NLRIのBGP-LSパスアトリビュートのキャプチャになります。Prefix SIDのIndexが格納されていることが確認できます。

コメント

タイトルとURLをコピーしました