今回はOSPFの認証において、特定のインタフェースで認証を無効にする方法ついて解説します。
座学
インタフェースでの認証の無効化
例えば、下図のR1とR2間では認証を行い、R2とR3間では認証を行いたくない状況において、R2でArea単位で認証を有効にした場合、R2とR3間のOSPFネイバーが確立できません。
このような状況でも、R2ではArea単位で認証を有効にし、かつ、R3とは認証無しでOSPFネイバーを確立した場合、R2のg3において、インタフェース単位でNull Authenticationを有効にする、すなわち、認証を無効にする必要があります。
実機での動作確認
検証内容
R1のg2、R2のg2でOSPF Area 0を有効にします。
Network TypeにはPoint-to-Pointを使用します。
R1でArea単位でSimple Authenticationを有効化した後、R1のg2でNull Authenticationを有効化します。
初期設定
interface GigabitEthernet2
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 1.1.1.1
network 10.1.1.0 0.0.0.255 area 0
interface GigabitEthernet2
ip address 10.1.1.2 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 2.2.2.2
network 10.1.1.0 0.0.0.255 area 0
認証設定前
OSPFプロセスの状態確認
R1のArea 0で認証が無効なことが確認できます。
R1#show ip ospf
Routing Process "ospf 1" with ID 1.1.1.1
.
<一部省略>
.
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:02:09.656 ago
SPF algorithm executed 17 times
Area ranges are
Number of LSA 2. Checksum Sum 0x012AA9
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
OSPFが動作しているインタフェースの状態確認
R1のg2で認証が無効なことが確認できます。
R1#show ip ospf interface
GigabitEthernet2 is up, line protocol is up
Internet Address 10.1.1.1/24, Interface ID 6, Area 0
Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
Helloパケットの確認
R1が送信したHelloパケットのAuthentication Typeが0(Null Authentication)であることが確認できます。
OSPFネイバーの状態確認
R1はR2とOSPFネイバーが確立できていることが確認できます。
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:37 10.1.1.2 GigabitEthernet2
Area単位でSimple Authを有効
R1のArea 0でSimple Authenticationを有効にします。認証のパスワードにはP@ssw0rdを使用します。
追加した設定
interface GigabitEthernet2
ip ospf authentication-key P@ssw0rd
!
router ospf 1
area 0 authentication
OSPFプロセスの状態確認
R1のArea 0でSimple Authetnicationが有効なことが確認できます。
R1#show ip ospf
Routing Process "ospf 1" with ID 1.1.1.1
.
<一部省略>
.
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has simple password authentication
SPF algorithm last executed 00:04:00.498 ago
SPF algorithm executed 17 times
Area ranges are
Number of LSA 2. Checksum Sum 0x012AA9
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
OSPFが動作しているインタフェースの状態確認
R1のg2でSimple Authetnicationが有効なことが確認できます。
R1#show ip ospf interface
GigabitEthernet2 is up, line protocol is up
Internet Address 10.1.1.1/24, Interface ID 6, Area 0
Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/2/2, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Simple password authentication enabled
Helloパケットの確認
R1が送信したHelloパケットのAuthentication Typeが1(Simple Authentication)であることが確認できます。
OSPFネイバーの状態確認
R1はR2とOSPFネイバーが確立できていないことが確認できます。
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
Area単位でSimple Authを有効 & I/F単位でNull Authenticationを有効
R1のArea 0でSimple Authenticationを有効にします。認証のパスワードにはP@ssw0rdを使用します。同時に、R1のg2でNull Authenticationを有効にします。
追加した設定
インタフェース単位でのNull Authenticationの有効化はip ospf authentication nullコマンドで可能です。
interface GigabitEthernet2
ip ospf authentication-key P@ssw0rd
ip ospf authentication null
!
router ospf 1
area 0 authentication
OSPFプロセスの状態確認
R1のArea 0でSimple Authetnicationが有効なことが確認できます。
R1#show ip ospf
Routing Process "ospf 1" with ID 1.1.1.1
.
<一部省略>
.
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has simple password authentication
SPF algorithm last executed 00:04:00.498 ago
SPF algorithm executed 17 times
Area ranges are
Number of LSA 2. Checksum Sum 0x012AA9
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
OSPFが動作しているインタフェースの状態確認
R1のg2で認証が無効なことが確認できます。
R1#show ip ospf interface
GigabitEthernet2 is up, line protocol is up
Internet Address 10.1.1.1/24, Interface ID 6, Area 0
Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
Helloパケットの確認
R1が送信したHelloパケットのAuthentication Typeが0(Null Authentication)であることが確認できます。
OSPFネイバーの状態確認
R1はR2とOSPFネイバーが確立できていることが確認できます。
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:37 10.1.1.2 GigabitEthernet2
コメント