今回はOSPFのLSAの再送間隔の変更方法について解説します。
この記事の目次
座学
LSUの再送間隔
OSPFではLSAの更新が発生した場合、LSU(Link State Update)に更新されたLSAを格納し、ネイバーに広報します。ネイバーはLSUパケットを受信後、LSAck(Link State Acknowledge)を返信します。
下図の様に、もし、R1がLSUを送信後、R2からLSAckを受信できない場合、R1はLSAckを返信しないネイバーに対してLSUをユニキャストで再送します。この再送間隔のことをRetransmit Intervalを呼びます。
実機での動作確認
検証内容
R1のg2、R2のg2でOSPF Area 0を有効にします。
Network TypeにはPoint-to-Pointを使用します。
R1でLSUの再送を発生させ、再送間隔を確認します。
初期設定
interface GigabitEthernet2
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 1.1.1.1
network 10.1.1.0 0.0.0.255 area 0
interface GigabitEthernet2
ip address 10.1.1.2 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 2.2.2.2
network 10.1.1.0 0.0.0.255 area 0
vlan 10
!
interface GigabitEthernet1/0/1
switchport mode access
switchport access vlan 10
!
interface GigabitEthernet1/0/2
switchport mode access
switchport access vlan 10
Retransmit Interval変更前
OSPFが動作しているインタフェースの状態確認
R1のOSPFのRetransmit Intervalが5秒であることが確認できます。
R1#show ip ospf interface
GigabitEthernet2 is up, line protocol is up
Internet Address 10.1.1.1/24, Interface ID 6, Area 0
Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
LSU再送時のR1の様子
R1は5秒間隔でLSUを再送していることが確認できます。
R1#debug ip ospf packet
*May 29 14:31:01.205: OSPF-1 PAK : Gi2: OUT: 10.1.1.1->224.0.0.5: ver:2 type:4 len:76 rid:1.1.1.1 area:0.0.0.0 chksum:6146 auth:0
*May 29 14:31:06.091: OSPF-1 PAK : Gi2: OUT: 10.1.1.1->10.1.1.2: ver:2 type:4 len:76 rid:1.1.1.1 area:0.0.0.0 chksum:6142 auth:0
*May 29 14:31:10.806: OSPF-1 PAK : Gi2: OUT: 10.1.1.1->10.1.1.2: ver:2 type:4 len:76 rid:1.1.1.1 area:0.0.0.0 chksum:613D auth:0
*May 29 14:31:15.677: OSPF-1 PAK : Gi2: OUT: 10.1.1.1->10.1.1.2: ver:2 type:4 len:76 rid:1.1.1.1 area:0.0.0.0 chksum:6138 auth:0
補足(LSUの再送を発生させる方法)
R2のg2をシャットダウン後、即座にR1のg2のOSPFのCostを変更し、R1にLSUを送信させることで、LSUの再送を発生させています。
interface GigabitEthernet2
shutdown
interface GigabitEthernet2
ip ospf cost 2
Retransmit Interval変更後
R1のg2のRetranstmit Intervalを10秒に変更します。
追加した設定
OSPFのRetransmit Intervalはip ospf retransmit-interval <second>コマンドで変更可能です。
interface GigabitEthernet2
ip ospf retransmit-interval 10
OSPFが動作しているインタフェースの状態確認
R1のOSPFのRetransmit Intervalが10秒に変化したことが確認できます。
R1#show ip ospf interface
GigabitEthernet2 is up, line protocol is up
Internet Address 10.1.1.1/24, Interface ID 6, Area 0
Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 10
oob-resync timeout 40
Hello due in 00:00:02
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
LSU再送時のR1の様子
R1は10秒間隔でLSUを再送していることが確認できます。
R1#debug ip ospf packet
*May 29 14:35:40.694: OSPF-1 PAK : Gi2: OUT: 10.1.1.1->224.0.0.5: ver:2 type:4 len:76 rid:1.1.1.1 area:0.0.0.0 chksum:6146 auth:0
*May 29 14:35:50.279: OSPF-1 PAK : Gi2: OUT: 10.1.1.1->10.1.1.2: ver:2 type:4 len:76 rid:1.1.1.1 area:0.0.0.0 chksum:6142 auth:0
*May 29 14:35:59.899: OSPF-1 PAK : Gi2: OUT: 10.1.1.1->10.1.1.2: ver:2 type:4 len:76 rid:1.1.1.1 area:0.0.0.0 chksum:613D auth:0
*May 29 14:35:09.240: OSPF-1 PAK : Gi2: OUT: 10.1.1.1->10.1.1.2: ver:2 type:4 len:76 rid:1.1.1.1 area:0.0.0.0 chksum:6138 auth:0
コメント