今回はOSPFのTotally Stub Areaについて解説します。
座学
Stub Area
前回の記事で、特定のAreaをStub Areaに指定することで、Stub Area内のLSAの情報量を削減できることを解説しました。
Totally Stub Areaと呼ばれる機能を使用することで、Totally Stub Area内のLSAの情報量をさらに削減可能です。ABRはTotally Stub Areaに対して、再配送されたルート情報を格納したLSA Type 5に加えて、他のAreaのルート情報を格納したLSA Type 3の広報を抑制します。代わりに、デフォルトルートを格納したLSA Type 3のみ広報します。
実機での動作確認
検証内容
R1のg2、R2のg2でOSPF Area 0を有効にします。
R2のg3、R3のg2でOSPF Area 2を有効にします。
Network TypeにはPoint-to-Pointを使用します。
R1でOSPFに対してConnected Routeである180.1.1.0/24を再配送します。
Area 2において、Stub Areaが有効な場合と、Totally Stub Areaが有効な場合とで、LSAの変化を確認します。
初期設定
interface GigabitEthernet2
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet3
ip address 180.1.1.1 255.255.255.0
!
router ospf 1
router-id 1.1.1.1
redistribute connected subnets
network 10.1.1.0 0.0.0.255 area 0
interface GigabitEthernet2
ip address 10.1.1.2 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet3
ip address 20.1.1.2 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 2.2.2.2
area 2 stub
network 10.1.1.0 0.0.0.255 area 0
network 20.1.1.0 0.0.0.255 area 2
interface GigabitEthernet2
ip address 20.1.1.3 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 3.3.3.3
area 2 stub
network 20.1.1.0 0.0.0.255 area 2
Totally Stub Area設定前
OSPFプロセスの状態確認
R2において、Area 2がStub Areaなことが確認できます。
R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 2w0d, Time elapsed: 00:53:10.071
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Supports Database Exchange Summary List Optimization (RFC 5243)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 50 msecs
Minimum hold time between two consecutive SPFs 200 msecs
Maximum wait time between two consecutive SPFs 5000 msecs
Incremental-SPF disabled
Initial LSA throttle delay 50 msecs
Minimum hold time for LSA throttle 200 msecs
Maximum wait time for LSA throttle 5000 msecs
Minimum LSA arrival 100 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
Number of external LSA 1. Checksum Sum 0x008560
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 1 normal 1 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:05:55.908 ago
SPF algorithm executed 9 times
Area ranges are
Number of LSA 3. Checksum Sum 0x01956C
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 1
It is a stub area
Generates stub default route with cost 1
Area has no authentication
SPF algorithm last executed 00:05:54.451 ago
SPF algorithm executed 16 times
Area ranges are
Number of LSA 4. Checksum Sum 0x02CF1D
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
LSDBの状態確認
R2はArea 2に対してArea 0の10.1.1.0/24を格納したLSA Type 3、0.0.0.0/0を格納したLSA Type 3を広報していることが確認できます。
R3#show ip ospf database
OSPF Router with ID (3.3.3.3) (Process ID 1)
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 209 0x8000000D 0x00F9D3 2
3.3.3.3 3.3.3.3 38 0x80000010 0x009036 2
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
0.0.0.0 2.2.2.2 210 0x80000001 0x0075C0
10.1.1.0 2.2.2.2 210 0x80000007 0x00CF54
SPFの計算結果の確認
R3は10.1.1.0/24と0.0.0.0/0を認識していることが確認できます。
R3#show ip ospf rib
OSPF Router with ID (3.3.3.3) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
*> 10.1.1.0/24, Inter, cost 2, area 2
via 20.1.1.2, GigabitEthernet2
* 20.1.1.0/24, Intra, cost 1, area 2, Connected
via 20.1.1.3, GigabitEthernet2
*> 0.0.0.0/0, Inter, cost 2, area 2
via 20.1.1.2, GigabitEthernet2
ルーティングテーブルの確認
R3のルーティングテーブルに10.1.1.0/24と0.0.0.0/0が投入されていることが確認できます。
R3#show ip route ospf
O*IA 0.0.0.0/0 [110/2] via 20.1.1.2, 00:04:43, GigabitEthernet2
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.1.1.0 [110/2] via 20.1.1.2, 00:04:43, GigabitEthernet2
疎通確認
R3の20.1.1.3からR1の10.1.1.1と180.1.1.1へのPingが成功することが確認できます。
R3#ping 10.1.1.1 source 20.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R3#ping 180.1.1.1 source 20.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 180.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Totally Stub Area設定後
Area 2でTotally Stub Areaを有効にします。
追加した設定
Totally Stub Area用のarea <area-id> stub no-summaryコマンドはABRに対して設定します。これにより、Totally Stub AreaのABRは、他のAreaのルート情報を格納したLSA Type 3の生成を抑制します。
router ospf 1
area 2 stub no-summary
OSPFプロセスの状態確認
R2において、Area 2に対して他のAreaのルート情報を格納したLSA Type 3を広報していないことが確認できます。
R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 2w0d, Time elapsed: 00:55:19.953
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Supports Database Exchange Summary List Optimization (RFC 5243)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 50 msecs
Minimum hold time between two consecutive SPFs 200 msecs
Maximum wait time between two consecutive SPFs 5000 msecs
Incremental-SPF disabled
Initial LSA throttle delay 50 msecs
Minimum hold time for LSA throttle 200 msecs
Maximum wait time for LSA throttle 5000 msecs
Minimum LSA arrival 100 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
Number of external LSA 1. Checksum Sum 0x008560
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 1 normal 1 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:00:14.352 ago
SPF algorithm executed 10 times
Area ranges are
Number of LSA 3. Checksum Sum 0x01956C
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 1
It is a stub area, no summary LSA in this area
Generates stub default route with cost 1
Area has no authentication
SPF algorithm last executed 00:00:14.352 ago
SPF algorithm executed 17 times
Area ranges are
Number of LSA 3. Checksum Sum 0x01FDCA
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
LSDBの状態確認
R2はArea 0の10.1.1.0/24を格納したLSA Type 3は生成せず、0.0.0.0/0を格納したLSA Type 3のみ生成していることが確認できます。
R3#show ip ospf database
OSPF Router with ID (3.3.3.3) (Process ID 1)
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 523 0x8000000D 0x00F9D3 2
3.3.3.3 3.3.3.3 353 0x80000010 0x009036 2
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
0.0.0.0 2.2.2.2 53 0x80000002 0x0073C1
SPFの計算結果の確認
R3は0.0.0.0/0のみ認識していることが確認できます。
R3#show ip ospf rib
OSPF Router with ID (3.3.3.3) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
* 20.1.1.0/24, Intra, cost 1, area 2, Connected
via 20.1.1.3, GigabitEthernet2
*> 0.0.0.0/0, Inter, cost 2, area 2
via 20.1.1.2, GigabitEthernet2
ルーティングテーブルの確認
R3のルーティングテーブルには0.0.0.0/0のみ投入されていることが確認できます。
R3#show ip route ospf
O*IA 0.0.0.0/0 [110/2] via 20.1.1.2, 00:04:43, GigabitEthernet2
疎通確認
R3の20.1.1.3からR1の10.1.1.1と180.1.1.1へのPingが成功することが確認できます。
R3#ping 10.1.1.1 source 20.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R3#ping 180.1.1.1 source 20.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 180.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
コメント