今回はOSPFのNSSAについて解説します。
座学
NSSA
NSSA(Not-So-Stubby Area)は、ASBRを配置可能なStub Areaになります。つまり、Stub Areaの特性を維持しつつ、Stub Areaに所属するルータで外部のルート情報をStub Areaに再配送可能です。
NSSAに再配送されたルート情報はNSSA AS External LSAと呼ばれるLSA Type 7に格納され、NSSA内にのみ広報されます。NSSAに所属するABRはLSA Type 7をLSA Type 5に変換し、他のAreaに広報します。
上図を見ると、R2はデフォルトルートを格納したLSAをNSSAに広報していないため、R3は180.1.1.0/24に到達できないのではないか、と疑問が生じた方もおられるかと思います。
Stub Areaの場合、Stub Areaから外部ネットワークへの出口はStub Area内のABRのみなので、Stub Area内のABRは自動的にデフォルトルートを格納したLSA Type 3を生成し、Stub Area内に広報します。
しかし、NSSAの場合、NSSAから外部ネットワークへの出口はNSSA内のABRとASBRの2つ存在するため、NSSA内のABRは自動的にデフォルトルートを格納したLSAを生成しません。(NSSA内のABRでデフォルトルートを格納したLSAを生成する方法はこちらの記事で解説しています。)
N bit
NSSAではLSA Type 7をサポートする必要があるため、NSSAに所属するルータが送信するHelloパケットのN(NSSA) bitには1がセットされます。また、NSSAではLSA Type 5は未サポートなので、E(External) bitには0がセットされます。ルータ間でOptionのN bitの値が異なる場合、ネイバーは確立できません(こちらの記事で解説しています)。
P bit
LSA Type 7ではP(Propagate) bitと呼ばれる値を使用します。(パケットフォーマットはLSA Type 5と同じです。)
NSSA内のABRはP bitが1にセットされたLSA Type 7のみLSA Type 5に変換して、他のAreaに広報します。
実機での動作確認
検証内容
R1のg2、R2のg2でOSPF Area 0を有効にします。
R2のg3、R3のg2でOSPF Area 2を有効にします。
Network TypeにはPoint-to-Pointを使用します。
R1でOSPFに対してConnected Routeである180.1.1.0/24を再配送します。
R3でOSPFに対してConnected Routeである190.1.1.0/24を再配送します。
Area 2でNSSAを有効化した際の状態を確認します。
初期設定
interface GigabitEthernet2
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet3
ip address 180.1.1.1 255.255.255.0
!
router ospf 1
router-id 1.1.1.1
redistribute connected subnets
network 10.1.1.0 0.0.0.255 area 0
interface GigabitEthernet2
ip address 10.1.1.2 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet3
ip address 20.1.1.2 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 2.2.2.2
network 10.1.1.0 0.0.0.255 area 0
network 20.1.1.0 0.0.0.255 area 2
interface GigabitEthernet2
ip address 20.1.1.3 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet3
ip address 190.1.1.3 255.255.255.0
!
router ospf 1
router-id 3.3.3.3
redistribute connected subnets
network 20.1.1.0 0.0.0.255 area 2
NSSA設定前
OSPFプロセスの状態確認
R2において、NSSAが無効なことが確認できます。
R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 2w0d, Time elapsed: 00:09:42.410
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Supports Database Exchange Summary List Optimization (RFC 5243)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 50 msecs
Minimum hold time between two consecutive SPFs 200 msecs
Maximum wait time between two consecutive SPFs 5000 msecs
Incremental-SPF disabled
Initial LSA throttle delay 50 msecs
Minimum hold time for LSA throttle 200 msecs
Maximum wait time for LSA throttle 5000 msecs
Minimum LSA arrival 100 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
Number of external LSA 2. Checksum Sum 0x014B6D
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:02:12.064 ago
SPF algorithm executed 4 times
Area ranges are
Number of LSA 4. Checksum Sum 0x0251D5
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:01:29.639 ago
SPF algorithm executed 4 times
Area ranges are
Number of LSA 4. Checksum Sum 0x0252A4
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Helloパケットの確認
R2が送信したHelloパケットのN bitに0、E bitに1がセットされていることが確認できます。
OSPFネイバーの状態確認
R2が送信したHelloパケットのE bitに1がセットされていることが確認できます。
R3#show ip ospf neighbor 2.2.2.2 detail
Neighbor 2.2.2.2, interface address 20.1.1.2, interface-id 7
In the area 2 via interface GigabitEthernet2
Neighbor priority is 0, State is FULL, 6 state changes
DR is 0.0.0.0 BDR is 0.0.0.0
Options is 0x12 in Hello (E-bit, L-bit)
Options is 0x52 in DBD (E-bit, L-bit, O-bit)
LLS Options is 0x1 (LR)
Dead timer due in 00:00:37
Neighbor is up for 00:41:41
Index 1/1/1, retransmission queue length 0, number of retransmission 0
First 0x0(0)/0x0(0)/0x0(0) Next 0x0(0)/0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec
LSDBの状態確認
R2はArea 2に対して10.1.1.0/24を格納したLSA Type 3、180.1.1.0/24を格納したLSA Type 5、ASBRであるR1のRouter IDを格納したLSA Type 4を広報していることが確認できます。
R3#show ip ospf database
OSPF Router with ID (3.3.3.3) (Process ID 1)
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 78 0x80000004 0x00EDE6 2
3.3.3.3 3.3.3.3 566 0x80000002 0x00943C 2
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 2.2.2.2 121 0x80000003 0x00B96C
Summary ASB Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
1.1.1.1 2.2.2.2 121 0x80000003 0x001716
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
180.1.1.0 1.1.1.1 574 0x80000001 0x008560 0
190.1.1.0 3.3.3.3 565 0x80000001 0x00C60D 0
R2はArea 0に対して20.1.1.0/24を格納したLSA Type 3、190.1.1.0/24を格納したLSA Type 5、ASBRであるR3のRouter IDを格納したLSA Type 4を広報していることが確認できます。
R1#show ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 550 0x80000002 0x00E313 2
2.2.2.2 2.2.2.2 101 0x80000004 0x007C74 2
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
20.1.1.0 2.2.2.2 59 0x80000003 0x0037E4
Summary ASB Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
3.3.3.3 2.2.2.2 59 0x80000003 0x00BA6A
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
180.1.1.0 1.1.1.1 554 0x80000001 0x008560 0
190.1.1.0 3.3.3.3 548 0x80000001 0x00C60D 0
SPFの計算結果の確認
R3は10.1.1.0/24と180.1.1.0/24を認識していることが確認できます。
R3#show ip ospf rib
OSPF Router with ID (3.3.3.3) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
*> 10.1.1.0/24, Inter, cost 2, area 2
via 20.1.1.2, GigabitEthernet2
* 20.1.1.0/24, Intra, cost 1, area 2, Connected
via 20.1.1.3, GigabitEthernet2
*> 180.1.1.0/24, Ext2, cost 20, fwd cost 2, tag 0
via 20.1.1.2, GigabitEthernet2
R2は180.1.1.0/24と190.1.1.0/24を認識していることが確認できます。
R2#show ip ospf rib
OSPF Router with ID (1.1.1.1) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
* 10.1.1.0/24, Intra, cost 1, area 0, Connected
via 10.1.1.2, GigabitEthernet2
* 20.1.1.0/24, Intra, cost 1, area 2, Connected
via 20.1.1.2, GigabitEthernet3
*> 180.1.1.0/24, Ext2, cost 20, fwd cost 1, tag 0
via 10.1.1.1, GigabitEthernet2
*> 190.1.1.0/24, Ext2, cost 20, fwd cost 1, tag 0
via 20.1.1.3, GigabitEthernet3
R1は20.1.1.0/24と190.1.1.0/24を認識していることが確認できます。
R1#show ip ospf rib
OSPF Router with ID (1.1.1.1) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
* 10.1.1.0/24, Intra, cost 1, area 0, Connected
via 10.1.1.1, GigabitEthernet2
*> 20.1.1.0/24, Inter, cost 2, area 0
via 10.1.1.2, GigabitEthernet2
*> 190.1.1.0/24, Ext2, cost 20, fwd cost 2, tag 0
via 10.1.1.2, GigabitEthernet2
ルーティングテーブルの確認
R3のルーティングテーブルに10.1.1.0/24と180.1.1.0/24が投入されていることが確認できます。
R3#show ip route ospf
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.1.1.0 [110/2] via 20.1.1.2, 00:41:57, GigabitEthernet2
180.1.0.0/24 is subnetted, 1 subnets
O E2 180.1.1.0 [110/20] via 20.1.1.2, 00:06:29, GigabitEthernet2
R2のルーティングテーブルに180.1.1.0/24と190.1.1.0/24が投入されていることが確認できます。
R2#show ip route ospf
180.1.0.0/24 is subnetted, 1 subnets
O E2 180.1.1.0 [110/20] via 10.1.1.1, 00:14:01, GigabitEthernet2
190.1.0.0/24 is subnetted, 1 subnets
O E2 190.1.1.0 [110/20] via 20.1.1.3, 00:13:57, GigabitEthernet3
R1のルーティングテーブルに20.1.1.0/24と190.1.1.0/24が投入されていることが確認できます。
R1#show ip route ospf
20.0.0.0/24 is subnetted, 1 subnets
O IA 20.1.1.0 [110/2] via 10.1.1.2, 00:05:37, GigabitEthernet2
190.1.0.0/24 is subnetted, 1 subnets
O E2 190.1.1.0 [110/20] via 10.1.1.2, 00:13:45, GigabitEthernet2
疎通確認
R3の20.1.1.3からR1の10.1.1.1と180.1.1.1へのPingが成功することが確認できます。
R3#ping 10.1.1.1 source 20.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R3#ping 180.1.1.1 source 20.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 180.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1の10.1.1.1からR3の20.1.1.3と190.1.1.3へのPingが成功することが確認できます。
R1#ping 20.1.1.3 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.3, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 190.1.1.3 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.1.3, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
NSSA設定後
Area 2でNSSAを有効にします。
追加した設定
NSSAはarea <area-id> nssaコマンドで有効化可能です。
今回はR2とR3において、Area 2でNSSAを有効化します。
router ospf 1
area 2 nssa
OSPFプロセスの状態確認
R2において、Area 2でNSSAが有効なことが確認できます。
R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 2w0d, Time elapsed: 00:20:12.017
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Supports Database Exchange Summary List Optimization (RFC 5243)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border and autonomous system boundary router
Redistributing External Routes from,
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 50 msecs
Minimum hold time between two consecutive SPFs 200 msecs
Maximum wait time between two consecutive SPFs 5000 msecs
Incremental-SPF disabled
Initial LSA throttle delay 50 msecs
Minimum hold time for LSA throttle 200 msecs
Maximum wait time for LSA throttle 5000 msecs
Minimum LSA arrival 100 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
Number of external LSA 2. Checksum Sum 0x008B19
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 1 normal 0 stub 1 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:00:32.302 ago
SPF algorithm executed 5 times
Area ranges are
Number of LSA 3. Checksum Sum 0x019B64
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 1
It is a NSSA area
Perform type-7/type-5 LSA translation
Area has no authentication
SPF algorithm last executed 00:00:24.623 ago
SPF algorithm executed 7 times
Area ranges are
Number of LSA 4. Checksum Sum 0x017BE6
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Helloパケットの確認
R2が送信したHelloパケットのN bitに1、E bitに0がセットされていることが確認できます。
OSPFネイバーの状態確認
R2が送信したHelloパケットのN bitに1、E bitに0がセットされていることが確認できます。
R3#show ip ospf neighbor 2.2.2.2 detail
Neighbor 2.2.2.2, interface address 20.1.1.2, interface-id 7
In the area 2 via interface GigabitEthernet2
Neighbor priority is 0, State is FULL, 6 state changes
DR is 0.0.0.0 BDR is 0.0.0.0
Options is 0x12 in Hello (N/P-bit, L-bit) <-- E-bitが表示されていない
Options is 0x52 in DBD (N/P-bit, L-bit, O-bit) <-- E-bitが表示されていない
LLS Options is 0x1 (LR)
Dead timer due in 00:00:37
Neighbor is up for 00:41:41
Index 1/1/1, retransmission queue length 0, number of retransmission 0
First 0x0(0)/0x0(0)/0x0(0) Next 0x0(0)/0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec
LSDBの状態確認
Area 2に存在するLSAを見ると、R3は190.1.1.0/24をLSA Type 7に格納してNSSA内に広報していることが確認できます。また、R2はArea 2に対して180.1.1.0/24を格納したLSA Type 5、ASBRであるR1のRouter IDを格納したLSA Type 4を広報してないことが確認できます。
R3#show ip ospf database
OSPF Router with ID (3.3.3.3) (Process ID 1)
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 287 0x80000008 0x009137 2
3.3.3.3 3.3.3.3 187 0x80000006 0x003294 2
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 2.2.2.2 254 0x80000006 0x0059C3
Type-7 AS External Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Tag
190.1.1.0 3.3.3.3 186 0x80000001 0x00525E 0
LSA Type 7の詳細はshow ip ospf database nssa-external <NSSAに再配送されたルート情報のネットワークアドレス> adv-router <LSAの生成元のルータのRouter ID>コマンドで確認可能です。
以下はR3が生成した190.1.1.0/24を格納したLSA Type 7になります。P bitに1がセットされていることが確認できます。
R3#show ip ospf database nssa-external 190.1.1.0 adv-router 3.3.3.3
OSPF Router with ID (3.3.3.3) (Process ID 1)
Type-7 AS External Link States (Area 2)
LS age: 371
Options: (No TOS-capability, Type 7/5 translation, DC, Upward)
LS Type: AS External Link
Link State ID: 190.1.1.0 (External Network Number )
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0x525E
Length: 36
Network Mask: /24
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 20.1.1.3
External Route Tag: 0
Area 0に存在するLSAを見ると、R2は190.1.1.0/24が格納されたLSA Type 7をLSA Type 5に変更して、Area 0に広報していることが確認できます。
R1#show ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 37 0x80000006 0x00DB17 2
2.2.2.2 2.2.2.2 232 0x80000007 0x007C6F 2
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
20.1.1.0 2.2.2.2 265 0x80000005 0x0033E6
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
180.1.1.0 1.1.1.1 30 0x80000003 0x008162 0
190.1.1.0 2.2.2.2 165 0x80000001 0x0005B9 0
以下はR2がLSA Type 7から変換した190.1.1.0/24が格納されたLSA Type 5になります。
R2#show ip ospf database external 190.1.1.0 adv-router 1.1.1.1
OSPF Router with ID (2.2.2.2) (Process ID 1)
Type-5 AS External Link States
LS age: 334
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 190.1.1.0 (External Network Number )
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x5B9
Length: 36
Network Mask: /24
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 20.1.1.3
External Route Tag: 0
SPFの計算結果の確認
R3は10.1.1.0/24のみ認識しており、180.1.1.0/24は認識していないことが確認できます。
R3#show ip ospf rib
OSPF Router with ID (3.3.3.3) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
*> 10.1.1.0/24, Inter, cost 2, area 2
via 20.1.1.2, GigabitEthernet2
* 20.1.1.0/24, Intra, cost 1, area 2, Connected
via 20.1.1.3, GigabitEthernet2
R2は180.1.1.0/24をLSA Type 5経由、190.1.1.0/24をLSA Type 7経由で認識していることが確認できます。
R2#show ip ospf rib
OSPF Router with ID (1.1.1.1) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
* 10.1.1.0/24, Intra, cost 1, area 0, Connected
via 10.1.1.2, GigabitEthernet2
* 20.1.1.0/24, Intra, cost 1, area 2, Connected
via 20.1.1.2, GigabitEthernet3
*> 180.1.1.0/24, Ext2, cost 20, fwd cost 1, tag 0
via 10.1.1.1, GigabitEthernet2
*> 190.1.1.0/24, NSSA2, cost 20, fwd cost 1, tag 0
via 20.1.1.3, GigabitEthernet3
R1は20.1.1.0/24と190.1.1.0/24を認識していることが確認できます。
R1#show ip ospf rib
OSPF Router with ID (1.1.1.1) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
* 10.1.1.0/24, Intra, cost 1, area 0, Connected
via 10.1.1.1, GigabitEthernet2
*> 20.1.1.0/24, Inter, cost 2, area 0
via 10.1.1.2, GigabitEthernet2
*> 190.1.1.0/24, Ext2, cost 20, fwd cost 2, tag 0
via 10.1.1.2, GigabitEthernet2
ルーティングテーブルの確認
R3のルーティングテーブルから180.1.1.0/24が消失したことが確認できます。
R3#show ip route ospf
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.1.1.0 [110/2] via 20.1.1.2, 00:41:57, GigabitEthernet2
R2のルーティングテーブルに180.1.1.0/24と190.1.1.0/24が投入されていることが確認できます。また、LSA Type 7経由で学習したルート情報の先頭にはN1、または、N2と表示されます。
R2#show ip route ospf
180.1.0.0/24 is subnetted, 1 subnets
O E2 180.1.1.0 [110/20] via 10.1.1.1, 00:14:01, GigabitEthernet2
190.1.0.0/24 is subnetted, 1 subnets
O N2 190.1.1.0 [110/20] via 20.1.1.3, 00:13:57, GigabitEthernet3
R1のルーティングテーブルに20.1.1.0/24と190.1.1.0/24が投入されていることが確認できます。
R1#show ip route ospf
20.0.0.0/24 is subnetted, 1 subnets
O IA 20.1.1.0 [110/2] via 10.1.1.2, 00:05:37, GigabitEthernet2
190.1.0.0/24 is subnetted, 1 subnets
O E2 190.1.1.0 [110/20] via 10.1.1.2, 00:13:45, GigabitEthernet2
疎通確認
R3の20.1.1.3からR1の10.1.1.1へのPingは成功し、180.1.1.1へのPingは失敗することが確認できます。
R3#ping 10.1.1.1 source 20.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R3#ping 180.1.1.1 source 20.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 180.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.3
.....
Success rate is 0 percent (0/5)
R1の10.1.1.1からR3の20.1.1.3と190.1.1.3へのPingが成功することが確認できます。
R1#ping 20.1.1.3 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.3, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 190.1.1.3 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.1.3, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
補足1
NSSAのABRはLSA Type 7を基にLSA Type 5を生成するため、自身がASBRであることを示すE(External) bitをセットしたLSA Type 1を生成します。
R1#show ip ospf database router adv-router 2.2.2.2
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
LS age: 288
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 2.2.2.2
Advertising Router: 2.2.2.2
LS Seq Number: 80000007
Checksum: 0x7C6F
Length: 48
Area Border Router
AS Boundary Router
Number of Links: 2
Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 1.1.1.1
(Link Data) Router Interface address: 10.1.1.2
Number of MTID metrics: 0
TOS 0 Metrics: 1
Link connected to: a Stub Network
(Link ID) Network/subnet number: 10.1.1.0
(Link Data) Network Mask: 255.255.255.0
Number of MTID metrics: 0
TOS 0 Metrics: 1
補足2
Area 0でNSSAの有効化を試みた際の様子
R1(config-router)#area 0 stub
% OSPF: Backbone can not be configured as NSSA area
NSSAが有効なルータがN bitに0がセットされたHelloパケットを受信した際の様子
R3#debug ip ospf hello
*May 3 06:05:29.595: OSPF-1 HELLO Gi2: Rcv hello from 2.2.2.2 area 1 20.1.1.2
*May 3 06:05:29.595: OSPF-1 HELLO Gi2: Hello from 20.1.1.2 with mismatched NSSA option bit
コメント