今回はOSPFのMulti AreaにおけるLSA Type 3のルート集約を解説します。
座学
LSA Type 3のルート集約
Multi Area構成において、あるAreaのルート情報を他のAreaに投入する際、ルート集約を行うことが可能です。また、デフォルトで、集約ルートを格納したLSA Type 3のCostには、集約前のルート情報の最小のCostが格納されます。
Discard Route
例えば、R2において、10.1.1.0/24と10.2.2.0/24を10.0.0.0/8に集約して、R1に広報したとします。また、同時に、R1はR2に対して0.0.0.0/0のデフォルトルートを広報したとします。
このような状況で、R1に10.3.3.3宛のパケットが届いた場合、R1はR2から学習した10.0.0.0/8を基に、10.3.3.3宛のパケットをR2に転送します。しかし、R2側には10.3.3.3に該当するネットワークは存在しないため、R2はR1から学習した0.0.0.0/0を基に、10.3.3.3宛のパケットをR1に転送します。このようにルート集約を行った場合、パケットのルーティングループが発生する可能性があります。
OSPFではルート集約に伴うルーティングループを回避するために、ルート集約を実施したルータのルーティングテーブルに、集約ルート宛のパケットを破棄するルート情報が追加されます。このルート情報のことをDiscard Routeと呼びます。
もし、R2が10.3.3.3の様な集約ルートには含まれるが、実際には存在しないネットワーク宛のパケットを受信した場合、R2はDiscard Routeを基にこのパケットを破棄します。
集約ルートに含まれており、かつ、実際には存在しているネットワーク宛のパケットが発生した場合、このパケットはロンゲストマッチにより、Discard Routeにはマッチせず、正しく転送されます。
実機での動作確認
検証内容
R1のg2でOSPF Area 0を有効にします。
R2のg2でOSPF Area 0、g3とg4でOSPF Area 2を有効にします。
R2のg3のOSPFのCostはデフォルト値の1を使用し、g4のOSPFのCostは5に変更します。
R1、R2のNetwork TypeにはPoint-to-Pointを使用します。
初期設定
interface GigabitEthernet2
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 1.1.1.1
network 10.1.1.0 0.0.0.255 area 0
interface GigabitEthernet2
ip address 10.1.1.2 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet3
ip address 20.1.1.2 255.255.255.0
!
interface GigabitEthernet4
ip address 20.2.2.2 255.255.255.0
ip ospf cost 5
!
router ospf 1
router-id 2.2.2.2
network 10.1.1.0 0.0.0.255 area 0
network 20.1.1.0 0.0.0.255 area 2
network 20.2.2.0 0.0.0.255 area 2
ルート集約設定前
OSPFプロセスの状態確認
R2のOSPFでルート集約が設定されていないことが確認できます。
R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 1d07h, Time elapsed: 00:00:37.969
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Supports Database Exchange Summary List Optimization (RFC 5243)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 50 msecs
Minimum hold time between two consecutive SPFs 200 msecs
Maximum wait time between two consecutive SPFs 5000 msecs
Incremental-SPF disabled
Initial LSA throttle delay 50 msecs
Minimum hold time for LSA throttle 200 msecs
Maximum wait time for LSA throttle 5000 msecs
Minimum LSA arrival 100 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:00:37.898 ago
SPF algorithm executed 1 times
Area ranges are
Number of LSA 4. Checksum Sum 0x019C77
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:00:14.945 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 2. Checksum Sum 0x010205
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
LSDBの状態確認
R2がArea 0に対して20.1.1.0/24と20.2.2.0/24を格納したLSA Type 3を投入していることが確認できます。
R2#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 46 0x80000013 0x00BB2C 2
2.2.2.2 2.2.2.2 45 0x80000002 0x008072 2
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
20.1.1.0 2.2.2.2 45 0x80000001 0x003BE2
20.2.2.0 2.2.2.2 22 0x80000001 0x0024F7
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 22 0x80000003 0x00449B 2
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 2.2.2.2 45 0x80000001 0x00BD6A
R2が生成した20.1.1.0/24を格納したLSA Type 3のCostが1なことが確認できます。
R2#show ip ospf database summary 20.1.1.0 adv-router 2.2.2.2
OSPF Router with ID (2.2.2.2) (Process ID 1)
Summary Net Link States (Area 0)
LS age: 61
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(Network)
Link State ID: 20.1.1.0 (summary Network Number)
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x3BE2
Length: 28
Network Mask: /24
MTID: 0 Metric: 1
R2が生成した20.2.2.0/24を格納したLSA Type 3のCostが5なことが確認できます。
R2#show ip ospf database summary 20.2.2.0 adv-router 2.2.2.2
OSPF Router with ID (2.2.2.2) (Process ID 1)
Summary Net Link States (Area 0)
LS age: 41
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(Network)
Link State ID: 20.2.2.0 (summary Network Number)
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x24F7
Length: 28
Network Mask: /24
MTID: 0 Metric: 5
SPFの計算結果の確認
R1はOSPF経由で20.1.1.0/24と20.2.2.0/24を学習していることが確認できます。
R1#show ip ospf rib
OSPF Router with ID (1.1.1.1) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
* 10.1.1.0/24, Intra, cost 1, area 0, Connected
via 10.1.1.1, GigabitEthernet2
*> 20.1.1.0/24, Inter, cost 2, area 0
via 10.1.1.2, GigabitEthernet2
*> 20.2.2.0/24, Inter, cost 6, area 0
via 10.1.1.2, GigabitEthernet2
ルーティングテーブルの確認
R1のルーティングテーブルに20.1.1.0/24と20.2.2.0/24が投入されていることが確認できます。
R1#show ip route ospf
20.0.0.0/24 is subnetted, 2 subnets
O IA 20.1.1.0 [110/2] via 10.1.1.2, 00:01:27, GigabitEthernet2
O IA 20.2.2.0 [110/6] via 10.1.1.2, 00:01:04, GigabitEthernet2
疎通確認
R1の10.1.1.1からR2の20.1.1.2と20.2.2.2へのPingが成功することが確認できます。
R1#ping 20.1.1.2 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 20.2.2.2 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Discard Routeの確認
ルート集約前なので、R2のルーティングテーブルにはDiscard Routeは追加されていないことが確認できます。
R2#show ip route
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, GigabitEthernet2
L 10.1.1.2/32 is directly connected, GigabitEthernet2
20.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 20.1.1.0/24 is directly connected, GigabitEthernet3
L 20.1.1.2/32 is directly connected, GigabitEthernet3
C 20.2.2.0/24 is directly connected, GigabitEthernet4
L 20.2.2.2/32 is directly connected, GigabitEthernet4
ルート集約設定後(集約ルートのコストの指定無し)
R2において、OSPFのArea 2のルート情報を20.0.0.0/8に集約し、他のAreaに広報します。また、集約ルートのコストには集約前ルートの最小コストを使用します。
追加したOPSFの設定
LSA Type 3を生成する際のルート集約はarea <area-id> range <network-address> <subnet-mask>コマンドで実施します。<area-id>で指定したArea のルート情報をLSA Type 3に変換し、他のAreaに広報する際に、ルート集約が行われます。
今回はR2において、Area 2のルート情報を20.0.0.0/8にルート集約し、Area 0に広報します。
router ospf 1
area 2 range 20.0.0.0 255.0.0.0
OSPFプロセスの状態確認
R2において、Area 2のルート情報を20.0.0.0/8にルート集約していることが確認できます。
R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 1d07h, Time elapsed: 00:12:18.544
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Supports Database Exchange Summary List Optimization (RFC 5243)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 50 msecs
Minimum hold time between two consecutive SPFs 200 msecs
Maximum wait time between two consecutive SPFs 5000 msecs
Incremental-SPF disabled
Initial LSA throttle delay 50 msecs
Minimum hold time for LSA throttle 200 msecs
Maximum wait time for LSA throttle 5000 msecs
Minimum LSA arrival 100 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:01:48.059 ago
SPF algorithm executed 4 times
Area ranges are
Number of LSA 3. Checksum Sum 0x018E6B
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:01:48.060 ago
SPF algorithm executed 15 times
Area ranges are
20.0.0.0/8 Active(16777215) Advertise
Number of LSA 2. Checksum Sum 0x0145BB
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
LSDBの状態確認
R2がArea 2に対して20.0.0.0/8を格納したLSA Type 3のみを投入していることが確認できます。
R2#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 754 0x80000013 0x00BB2C 2
2.2.2.2 2.2.2.2 753 0x80000002 0x008072 2
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
20.0.0.0 2.2.2.2 123 0x80000001 0x0052CD
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 235 0x80000005 0x008851 2
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 2.2.2.2 753 0x80000001 0x00BD6A
R2が生成した20.0.0.0/8を格納したLSA Type 3のCostが1なので、集約前ルートの20.1.1.0/24のCost が使用されていることが確認できます。
R2#show ip ospf database summary 20.0.0.0 adv-router 2.2.2.2
OSPF Router with ID (2.2.2.2) (Process ID 1)
Summary Net Link States (Area 0)
LS age: 136
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(Network)
Link State ID: 20.0.0.0 (summary Network Number)
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x52CD
Length: 28
Network Mask: /8
MTID: 0 Metric: 1
SPFの計算結果の確認
R1はOSPF経由で20.0.0.0/8のみを学習していることが確認できます。また、Costは2(R1-R2間のCost 1+ 20.1.1.0/24のCost 1)であることが確認できます。
R1#show ip ospf rib
OSPF Router with ID (1.1.1.1) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
* 10.1.1.0/24, Intra, cost 1, area 0, Connected
via 10.1.1.1, GigabitEthernet2
*> 20.0.0.0/8, Inter, cost 2, area 0
via 10.1.1.2, GigabitEthernet2
ルーティングテーブルの確認
R1のルーティングテーブルには20.0.0.0/8のみ投入されていることが確認できます。また、20.0.0.0/8のCostが2であることが確認できます。
R1#show ip route ospf
O IA 20.0.0.0/8 [110/2] via 10.1.1.2, 00:02:36, GigabitEthernet2
疎通確認
R1の10.1.1.1からR2の20.1.1.2と20.2.2.2へのPingが成功することが確認できます。
R1#ping 20.1.1.2 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 20.2.2.2 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Discard Routeの確認
ルート集約後なので、R2のルーティングテーブルにネクストホップがNull0の20.0.0.0/8宛のDiscard Routeが追加されていることが確認できます。
R2#show ip route
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, GigabitEthernet2
L 10.1.1.2/32 is directly connected, GigabitEthernet2
20.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
O 20.0.0.0/8 is a summary, 00:01:22, Null0
C 20.1.1.0/24 is directly connected, GigabitEthernet3
L 20.1.1.2/32 is directly connected, GigabitEthernet3
C 20.2.2.0/24 is directly connected, GigabitEthernet4
L 20.2.2.2/32 is directly connected, GigabitEthernet4
ルート集約設定後(集約ルートのコストの指定有り)
R2において、OSPFのArea 2のルート情報を20.0.0.0/8に集約し、他のAreaに広報します。また、集約ルートのコストには8を格納します。
追加したOPSFの設定
ルート集約のコストはarea <area-id> range <network-address> <subnet-mask> cost <cost>コマンドで設定します。
今回はR2において、20.0.0.0/8の集約ルートのCostに8を格納します。
router ospf 1
area 2 range 20.0.0.0 255.0.0.0 cost 8
OSPFプロセスの状態確認
show ip ospfコマンドでは集約ルートに対して明示的に設定したCostの値は確認できません。
R2#show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
Start time: 1d07h, Time elapsed: 00:15:48.908
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Supports Database Exchange Summary List Optimization (RFC 5243)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 50 msecs
Minimum hold time between two consecutive SPFs 200 msecs
Maximum wait time between two consecutive SPFs 5000 msecs
Incremental-SPF disabled
Initial LSA throttle delay 50 msecs
Minimum hold time for LSA throttle 200 msecs
Maximum wait time for LSA throttle 5000 msecs
Minimum LSA arrival 100 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
EXCHANGE/LOADING adjacency limit: initial 300, process maximum 300
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:01:48.059 ago
SPF algorithm executed 4 times
Area ranges are
Number of LSA 3. Checksum Sum 0x018E6B
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 2
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:01:48.060 ago
SPF algorithm executed 15 times
Area ranges are
20.0.0.0/8 Active(16777215) Advertise
Number of LSA 2. Checksum Sum 0x0145BB
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
LSDBの状態確認
R2がArea 2に対して20.0.0.0/8を格納したLSA Type 3のみを投入していることが確認できます。
R2#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 970 0x80000013 0x00BB2C 2
2.2.2.2 2.2.2.2 969 0x80000002 0x008072 2
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
20.0.0.0 2.2.2.2 80 0x80000004 0x009283
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 451 0x80000005 0x008851 2
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 2.2.2.2 969 0x80000001 0x00BD6A
R2が生成した20.0.0.0/8を格納したLSA Type 3のCostに8が格納されていることが確認できます。
R2#show ip ospf database summary 20.0.0.0 adv-router 2.2.2.2
OSPF Router with ID (2.2.2.2) (Process ID 1)
Summary Net Link States (Area 0)
LS age: 92
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(Network)
Link State ID: 20.0.0.0 (summary Network Number)
Advertising Router: 2.2.2.2
LS Seq Number: 80000004
Checksum: 0x9283
Length: 28
Network Mask: /8
MTID: 0 Metric: 8
SPFの計算結果の確認
R1はOSPF経由で20.0.0.0/8のみを学習していることが確認できます。また、Costは9(R1-R2間のCost 1+ 20.1.1.0/24のCost 8)であることが確認できます。
R1#show ip ospf rib
OSPF Router with ID (1.1.1.1) (Process ID 1)
Base Topology (MTID 0)
OSPF local RIB
Codes: * - Best, > - Installed in global RIB
* 10.1.1.0/24, Intra, cost 1, area 0, Connected
via 10.1.1.1, GigabitEthernet2
*> 20.0.0.0/8, Inter, cost 9, area 0
via 10.1.1.2, GigabitEthernet2
ルーティングテーブルの確認
R1のルーティングテーブルには20.0.0.0/8のみ投入されていることが確認できます。また、20.0.0.0/8のCostが9であることが確認できます。
R1#show ip route ospf
O IA 20.0.0.0/8 [110/9] via 10.1.1.2, 00:02:36, GigabitEthernet2
疎通確認
R1の10.1.1.1からR2の20.1.1.2と20.2.2.2へのPingが成功することが確認できます。
R1#ping 20.1.1.2 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 20.2.2.2 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Discard Routeの確認
ルート集約後なので、R2のルーティングテーブルにネクストホップがNull0の20.0.0.0/8宛のDiscard Routeが追加されていることが確認できます。
R2#show ip route
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, GigabitEthernet2
L 10.1.1.2/32 is directly connected, GigabitEthernet2
20.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
O 20.0.0.0/8 is a summary, 00:01:22, Null0
C 20.1.1.0/24 is directly connected, GigabitEthernet3
L 20.1.1.2/32 is directly connected, GigabitEthernet3
C 20.2.2.0/24 is directly connected, GigabitEthernet4
L 20.2.2.2/32 is directly connected, GigabitEthernet4
コメント