今回はLISPで学習したEID-PrefixをOSPFやBGPなどのルーティングプロトコルに再配送する方法を説明します。
概要
LISPからルーティングプロトコルへの再配送
LISPで学習したEID-PrefixをOSPFやBGPに再配送するには、最初にEID-PrefixをRIBにエクスポートする必要があります。その後、RIBにエクスポートされたEID-PrefixをOSPFやBGPに再配送します。
ただし、1点制約が存在し、LISPで学習したEID-PrefixをRIBにエクスポート可能なのはMSのみで、xTRではエクスポート不可です。
LISPでは、xTRとMSを共存させることが可能です。そのため、LISPで学習したEID-Prefixを拠点内の別のルータに広報したいxTRでMSも動作させれば、LISPからOSPFやBGPへの再配送が円滑にできます。
検証の基本設定
基本設定の内容
R2をMR/MS、R3をxTRとして動作させます。
R3はEID-Prefixが10.2.2.0/24、RLOCが172.16.1.3のマッピング情報をR2に登録します。
R1とR2間でOSPFを動作させます。エリアは0とします。
R2において、LISPで学習した10.2.2.0/24をOSPFに再配送します。
基本設定
interface GigabitEthernet2
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
router ospf 1
router-id 1.1.1.1
network 10.1.1.0 0.0.0.255 area 0
interface GigabitEthernet2
ip address 10.1.1.2 255.255.255.0
ip ospf network point-to-point
!
interface GigabitEthernet3
ip address 172.16.1.2 255.255.255.0
!
router lisp
service ipv4
map-server
map-resolver
exit-service-ipv4
!
instance-id 0
service ipv4
eid-table default
route-export site-registrations
exit-service-ipv4
!
exit-instance-id
!
site Site_1
authentication-key Zaq12wsx!@
eid-record 10.2.2.0/24
exit-site
!
exit-router-lisp
!
router ospf 1
router-id 2.2.2.2
redistribute lisp
network 10.1.1.0 0.0.0.255 area 0
interface GigabitEthernet2
ip address 172.16.1.3 255.255.255.0
!
interface GigabitEthernet3
ip address 10.2.2.3 255.255.255.0
!
router lisp
service ipv4
itr map-resolver 172.16.1.2
itr
etr map-server 172.16.1.2 key Zaq12wsx!@
etr
exit-service-ipv4
!
instance-id 0
service ipv4
eid-table default
database-mapping 10.2.2.0/24 172.16.1.3 priority 1 weight 50
exit-service-ipv4
!
exit-instance-id
!
exit-router-lisp
interface GigabitEthernet2
ip address 10.2.2.4 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.2.2.3
設定内容と状態の確認
設定確認
MR/MSであるR2の設定を確認します。
route-export site-registrationsコマンドを設定することで、Mapping Databaseに登録されているEID-PrefixをRIBにエクスポートできます。
redistribute lispコマンドを設定することで、RIBにエクスポートしたEID-Prefixをルーティングプロトコルに再配送できます。
router lisp
instance-id 0
service ipv4
eid-table default
route-export site-registrations
exit-service-ipv4
!
exit-instance-id
!
!
router ospf 1
redistribute lisp
状態確認
LISP、OSPF、RIBの各種状態を確認します。
R1のLISPのMapping Databaseに10.2.2.0/24が登録されていることが確認できます。
R2#show lisp site detail
LISP Site Registration Information
Site name: Site_1
Allowed configured locators: any
Allowed EID-prefixes:
EID-prefix: 10.2.2.0/24
First registered: 00:07:47
Last registered: 00:07:43
Routing table tag: 0
Origin: Configuration
Merge active: No
Proxy reply: No
Skip Publication: No
Force Withdraw: No
TTL: 1d00h
State: complete
Registration errors:
Authentication failures: 0
Allowed locators mismatch: 0
ETR 172.16.1.3:22546, last registered 00:07:43, no proxy-reply, map-notify
TTL 1d00h, no merge, hash-function sha1, nonce 0x31B3B55C-0xF8A77CF2
state complete, no security-capability
xTR-ID 0xB6A10567-0xE8C40F82-0x12854B1A-0x5EE69FFB
site-ID unspecified
Domain-ID unspecified
Multihoming-ID unspecified
sourced by reliable transport
Locator Local State Pri/Wgt Scope
172.16.1.3 yes up 1/50 IPv4 none
R2において、LISPで学習したEID-Prefixの10.2.2.0/24がRIBにエクスポートされていることが確認できます。
R2#show ip route lisp
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
l 10.2.2.0/24 [10/1], 00:06:54, Null0
R2において、LISPで学習したEID-Prefixの10.2.2.0/24がLSDBにLSAタイプ5として投入されていることが確認できます。
R2#show ip ospf database external
OSPF Router with ID (2.2.2.2) (Process ID 1)
Type-5 AS External Link States
LS age: 387
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 10.2.2.0 (External Network Number )
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0xFA8F
Length: 36
Network Mask: /24
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 0.0.0.0
External Route Tag: 0
R1はOSPF経由でEID-Prefixの10.2.2.0/24を学習していることが確認できます。
R1#show ip route ospf
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O E2 10.2.2.0/24 [110/20] via 10.1.1.2, 00:06:45, GigabitEthernet2
コメント